Lag on Ipad

Technical issues and bugs for the mobile version.
User avatar
CommanderXXX
Space Cadet
Space Cadet
Posts: 2
Joined: Thu May 02, 2013 7:07 am

Lag on Ipad

Post by CommanderXXX » Thu May 02, 2013 7:16 am

I have been playing this game for 1 or 2 hours when the game begane to lag incredible much. I have tried to fix it by delting apps and other things from the ipad and i have also restarted it several times. But nothing has helped it

User avatar
Zavier
Non-Dev Member
Non-Dev Member
Posts: 1108
Joined: Thu Dec 13, 2012 10:44 pm

Re: Lag on Ipad

Post by Zavier » Thu May 02, 2013 7:31 am

This can happen on the older devices like the ipad1 and itouch4.

Turn the iPad off completely or force close all apps. Double tap the home button, a new bar shows up on the bottom. Press the icons there until an x appears. Close all the apps by pressing the x's.

Enjoy!

-Zavier
I am a volunteer player and do not work for War Balloon

User avatar
rasmusdc
Space Cadet
Space Cadet
Posts: 3
Joined: Thu May 02, 2013 2:37 pm

Re: Lag on Ipad

Post by rasmusdc » Thu May 02, 2013 2:41 pm

Same issues on ipad3 game really slow after the first 7-8 missions.. Reboot and full reset does not help. The fun part is that there's the same amount of action on the screen as when it ran smooth.

Had the dead crew outside ship bug too...

The game is really cool, but unplayable, works fine on iphone5, but to small screen to play on.

User avatar
Uttrik
Space Cadet
Space Cadet
Posts: 4
Joined: Thu May 02, 2013 5:02 pm

Re: Lag on Ipad

Post by Uttrik » Thu May 02, 2013 5:08 pm

I am having the same issue on an iPhone 4. It was getting progressively more laggy as I finished each mission and now the game has become almost unplayable upon finishing up the group of missions in the Tarsus system. I have turned off every other app and restarted my phone, neither helped the lag.

Edit:
iPhone 4 running iOS 6.1.3.

Edit 2:
It appears to the upgrades that are causing it. I loaded an autosave and each upgrade placed has a noticeable effect on the smoothness of the game. With just two upgrades in each room, the lag is bad enough for the game to be unplayable.

User avatar
KARIXON
Space Cadet
Space Cadet
Posts: 4
Joined: Thu May 02, 2013 11:05 pm

Re: Lag on Ipad

Post by KARIXON » Thu May 02, 2013 11:08 pm

I have the same problems on the iPad Mini - seems like the upgrades are somehow the cause (like the poster above me suggested). I'm about an hour and a half in and the game is nearly unplayable - I can't survive a battle due to the lag.

Running iPad Mini - Latest Firmware
Normal Mode
Ship fully upgraded
1.5 hours in (I don't want to spoil anything by describing the plot, especially on the day of release)

User avatar
omichron
Space Cadet
Space Cadet
Posts: 1
Joined: Thu May 02, 2013 11:11 pm

Re: Lag on Ipod too

Post by omichron » Thu May 02, 2013 11:37 pm

I see the same issue with upgrades. Had a very heavily damaged ship, everything was running smooth.

Spent some time in friendly zone, repaired everything, added some upgrades to about 3 rooms, and suddenly the game went to 1 fps (no exaggeration).

Current Setup (laggy):
Bridge - no upgrades
Dodge Generator - Full upgrades
Healing Room - Clean Room + Science Futon
Engine - Synchro Maximo
Laser Cannon (top spot) - Minigame emultaor, Delta Oscillator
Machine Gun - Gun Control
8 Crew

Saved Previous Setup (not laggy)
Bridge - no changes
Dodge Generator - No inertia console
Healing Room - no changes
Engine - no changes
Laser Cannon (top spot) - no Delta Oscillator
Machine Gun - no changes

So I re-apply inertia and delta. Still not laggy.

Then, I repair my ship (it's full of hull breaches and roaring fires. I lost one of my engineers due to careless pathing).

As son as the engine room is fixed (not looking like a warzone), the game turns laggy. The very frame where the huge engine gets repaired so it doesn't look battle-scarred.

I load the previous non-laggy game, apply no upgrades, and head to the engine (still has the synchro maximo upgrade and battle damage). I fix the room enough and surely, the lag occurs on the very frame that the texture changes from battle-damaged to 'good as new'.

I don't think this is a hardware issue.
This is the image of how it looks like when it's not lagging Image
And this is it, a second after, lagging Image

If there was a way to send you my save files, I would.

User avatar
KARIXON
Space Cadet
Space Cadet
Posts: 4
Joined: Thu May 02, 2013 11:05 pm

Re: Lag on Ipad

Post by KARIXON » Thu May 02, 2013 11:44 pm

Yeah, I can't even play anymore. Just to note - I've closed all background apps, turned off and turned the iPad on and tried a host of other things. Here's hoping this gets fixed soon.

User avatar
paracelus
Space Cadet
Space Cadet
Posts: 5
Joined: Wed Feb 20, 2013 4:33 am

Re: Lag on Ipad

Post by paracelus » Fri May 03, 2013 1:32 am

Same here, on iPad Mini. Lots of upgrades, lags. Tried rebooting etc, no difference. Having other ships near you also seems to trigger it. Makes for very difficult battles. Any word from the devs on this issue? Surely this must have come up during testing?

User avatar
bluspacecow
Space Cadet
Space Cadet
Posts: 3
Joined: Fri May 03, 2013 1:09 am

Re: Lag on Ipad

Post by bluspacecow » Fri May 03, 2013 1:34 am

Star command has it's own little tab in the Settings app where you can turn off animations.

It's at the bottom under "Star Command". You need to scroll down to see it.

In it try turning off room animations.

IE

Settings -> Scroll down -> Star Command -> Load room animations -> Set to off

Image

Image

Image

EDIT: Corrected name of settings app :|
Last edited by bluspacecow on Fri May 03, 2013 1:49 am, edited 1 time in total.

User avatar
bluspacecow
Space Cadet
Space Cadet
Posts: 3
Joined: Fri May 03, 2013 1:09 am

Re: Lag on Ipad

Post by bluspacecow » Fri May 03, 2013 1:40 am

Also after changing the settings you may want to :

1) Save your game
2) Switch to the home screen using the home button
3) Double click the home button and quit Star Command (hold down till it shakes then close it)
4) Start Star Command back up and re-load

As I'm not 100% sure the changed settings take affect right away.

I'm also not experiencing this issue so have no idea if this will do anything for you. Let us know :P
Last edited by bluspacecow on Fri May 03, 2013 1:49 am, edited 1 time in total.

Post Reply